epitalon

Excel Dersleri

Bu örnek sayfa üzerindeki button;

Yeni bir sayfa tanımlar,
İsmini bulunduğu sayfa isimini yedek olarak alır,
Eğer aynı isimli benzer bir sayfa varsa siler
Button’un bulunduğu sayfayı komple kopyalarak, yeni oluşturulan sayfaya, pastespecial/values olarak yapıştırır.

Örnek excel bu linkten ulaşabilirsiniz. Link

Etiketler:

Selamlar,
İş yoğunluğu nedeni ile uzun süredir ilgilenemiyordum site ile. Geçenlerde bir müdür yardımcı arkadaşımızın ricası üzerine personel devam-devamsızlıkları ile ilgili bir çalışma yaptım. Onu paylaşmak istedim. Umarım diğer öğretmen arkadaşlar içinde yararlı bir çalışma olmuştur.
Exceli buradan indirebilirsiniz. İlk sayfada nasıl kullanması gerektiğine dair bir kaç kelam sarfettim.
Devam-Devamsızlık Çizelgesi

Excel’de tarih ile ilgili işlemler yapmadan önce tarih bilgisinin nasıl tutulduğunu anlamak gerekir. Excel’de tarih bilgisi; gün bazlı olarak 1900 yılının 1 Ocak gününden itibaren geçen gün olarak tutulur.
Araçlar menüsü altındaki “Seçenekler”den bu referans tarihini isterseniz 1904 olarak değiştirebilirsiniz.

Hemen bir ufak deneme ile tarih sistemimizin ne olduğunu öğrenelim. Bir hücre seçip içine “01.01.1900” yazalım sonrada [...]

Excel’in farklı kaynaklardan veri alışverişi mümkündür. Kabaca en çok kullanılan dört kaynak aşağıda sıralanmıştır.
1. SQL veri tabanı
2. Acces Dosyaları
3. Excel Dosyası (Aynı çalışma kitabı dahil*)
4. İnternet sayfaları
Veri sekmesi altında “Dış Veri Al” sihirbazı ile işiniz oldukça kolay. “Veri Al” menüsü ile bilgisayarınıza kayıtlı tüm kaynaklardan rahatlıkla veri çekebilirsiniz. Bu olayı makro kaydederek yaptığınızda göreceğiniz kodlarda [...]

Sıra geldi Excel’in bir güzel özelliğine daha. Adı koşullu biçimlendirme. Dosya menüsünden biçim sekmesinin altında bulunan bu güzel alet oldukça faydalı ve yararlı bir işlev. Özellikle yoğun rakam bulunan tablolarda rakamları daha anlamlı ve okunaklı hale getirmek için bire bir. Hücre içindeki değerin belirlediniz koşullar çerçevesinde durumuna bakarak görselliğini ayarlayabildiğiniz bir özellik bu koşullu biçimlendirme. [...]

Pivot tabloda sürükle bırak ve sağ tuş-alan ayarları ile yapabileceklerinizin tamamını anlatmaya kalksam herhalde blog dolar taşar. Üşenmeyin deneyin, neler var neler göreceksiniz. Şimdi ise biraz daha uç örnekler verelim.
 
Şimdi mağazada ürün yönetiminde çalıştığımızı düşünelim. Elimizde ürünlerin adları, bağlı bulundukları kategoriler (mesela reyonlar ) ile eki ve güncel fiyatları mevcut olsun. Toplam mağazanın uyguladığı efektif [...]

Evet geldik Excel’i Excel yapan en temel özelliklerden birine. Pivot tablo özelliği.
Az çok datayla uğraşmış olanlar SQL yada Access kullananlar pivot özelliğini bilmektedirler. Ama Excel’in pivot tablosu gerçekten çok farklıdır. Çoklu ve kademeli pivot özelliği ne Access’de ne de SQL’de mevcuttur. Ayrıca pivot üzerinden hesaplanmış alan üretebilmek, pivot alanları için tanımlı onlarca formülü kullanabilmek….
Neyse biz [...]

İlk anlattıklarımız metni parçalamak üzerineydi. Gelin şimdi de parçalanmış metinleri birleştirme nasıl olurmuş ona bakalım.
 
Sa/Su   A                                 B
1          Burhan Altıntop            Bilgisayar
2          Burhan Altıntop            Masa
3          Burhan Altıntop            Saat
4          Burhan Altıntop            Kalem
 
Ayrık datalarımızı tek hücre içinde birleştirelim bakalım. Bunun için bir formülden ziyade mantıksal birleştirici operatör olan & (mantıksal VE) ‘i kullanacağız.
 
=A1&B1 sonuç maalesef şöyle olacaktır. “Burhan AltıntopBilgisayar”
 
Genelde [...]

Excel’de hücre içinde bulunan metinleri istediğiniz gibi parçalama yapabilir, benzer şekilde de birkaç ayrı hücre içeriğini de tek bir hücre içinde istediğiniz gibi birleştirebilirsiniz.
Excel’in standart kütüphanesinde metinlerle ilgili yeteri kadar fonksiyon barındırmakta. Örnek verecek olursak;
=PARÇAAL(metin; başlangıç_sayısı, uzunluk)
Excel’i Türkçe olmayanlar için Parçaal fonksiyonun karşılığı =MID() ‘dir.
Örneğin elimizde bulunan listede bir hücre içinde müşterinin adı ve aldığı [...]

Eğer il ilgili diğer fonksiyonlar EĞERSAY ve ETOPLA’dır. Verilen şart sağlandığında sayım yada toplam tapar.
= ETOPLA(aralık;ölçüt;toplam_aralığı)
=EĞERSAY(aralık; ölçüt)

 Yukarıdaki tablodan erkek deneklerin yaş toplamlarını ve sayılarını bulalım
Toplam Yaş =ETOPLA(B2:B11;“=E”;C2:C11)
Toplam Sayı =EĞERSAY(B2:B11;”=E”)
Böylece deneye katılan erkeklerin ortalama yaşı
=ETOPLA(B2:B11;“=E”;C2:C11)/ EĞERSAY(B2:B11;”=E”)
Formülü ile hesaplanmış olur. Tabi böyle bir tabloda bunu elden hesaplamak daha kolay ama işin karmaşıklaştığı uzun ve karışık tablolar için [...]